Потенциальная угроза в модуле Minify 8.5-10.0

Потенциальная угроза в модуле Minify

Проблема: Недостаточная фильтрация данных в модуле сжатия файлов Minify входящем в состав DLE (https://code.google.com/p/minify/), которая может позволить при определенных настройках серверного ПО читать содержимое файлов.
Степень опасности: Высокая
 
Установка:
1. Для исправления следует открыть engine/classes/min/index.php и в самом начале, после строчки:
<?php

Добавить ниже:
if (isset($_GET['f'])) { 
       $_GET['f'] = str_replace(chr(0), '', (string)$_GET['f']); 
} 

Готово!
 
Версия DLE: 8.5-10.0
Автор: celsoft
Источник:
  • Oxigen
  • 0
  • 173
Информация
Оставлять комментарии могут только зарегистрированные посетители.
  • Рейтинг@Mail.ru
  • Яндекс.Метрика