Важное исправление для BulletShare Board 1.3

Важное исправление для BulletShare Board 1.3

Этот патч исправляет функции для администрирования и быстрого редактирования форума BulletShare Board 1.3:
  • При администрировании - не возможность создать подфорум без ошибки в MySQL.
  • При быстром редактировании - возникает ошибка с движком DataLife 13.3. Эта ошибка касается файла engine/modules/sitelogin.php.
Установка:
1. Для исправления открыть engine/modules/sitelogin.php и в строке 158 найти:
for($i = 0; $i < 9; $i ++) {
				$hash .= $salt{mt_rand( 0, 39 )};
			}

Заменить на:
for($i = 0; $i < 9; $i ++) {
				$hash .= $salt[mt_rand( 0, 39 )];
			}

Если нет желания редактировать этот файл, то можно использовать sitelogin.php из дистрибутива DataLife Engine 14.0.

2. Установите патч, скачав архив и загрузив его содержимое в корень вашего сайта, а именно в папку engine.
Скачать: cоздайте аккаунт или авторизуйтесь для скачивания файла.
 
Кодировка: utf-8
 
Автор: DarkLane
Источник:
  • DarkLane
  • 2
  • 869
Информация
Посетители, находящиеся в группе Гость, не могут оставлять комментарии к данной публикации.

Комментариев 2

DarkLane 18 июня 2021 17:29
Risha,
Откройте файл engine/forum/ajax/init.php и удалите его
require_once ENGINE_DIR . '/classes/plugins.class.php';

Для файла engine/forum/sources/modules/uploads.php я не понимаю, потому что там нет ничего, что вызывает класс plugins
Risha 17 июня 2021 20:08
ОШИБКИ ФОРУМА для DLE 13.3:
1. при загрузке фалов на сервер attachment - не работает на 13,3:
Fatal error: Uncaught Error: Class 'DLEPlugins' not found in /home/admin/sites/pedforum.kz/engine/modules/functions.php:46 Stack trace: #0 /home/admin/sites/pedforum.kz/engine/forum/sources/modules/uploads.php(32): require_once() #1 {main} thrown in /home/admin/sites/pedforum.kz/engine/modules/functions.php on line 46

2. при быстром ответе на сообщение
Fatal error: Uncaught Error: Class 'DLEPlugins' not found in /home/admin/sites/pedforum.kz/engine/modules/functions.php:46 Stack trace: #0 /home/admin/sites/pedforum.kz/engine/forum/ajax/init.php(33): require_once() #1 /home/admin/sites/pedforum.kz/engine/forum/ajax/addpost.php(16): include('/home/admin/sit...') #2 {main} thrown in /home/admin/sites/pedforum.kz/engine/modules/functions.php on line 46